Yes, you can use the app with partner communities. Please make sure you have app package versionĀ 1.952.3 or later installed into your Salesforce.